Troubleshooting Project Analysis Issues

Following are issues that may occur involving background code when working in Flare.

Analysis feature in Flare does not work

When using the analysis feature in Flare, the following error message occurs:

Problem(s) in FileList background thread: Index was out of range. Must be non-negative and less than the size of the collection.

Cause

The analysis database may be corrupted. This can be the result of a Microsoft SQL writing problem.

Solution

Delete the Analyzer folder from the Flare project. This will remove the corrupted analysis database. Flare will then generate a new database the next time that you open the project.

To accomplish this, perform the following steps.

  1. Close the project in Flare.
  2. Open the project folder in Windows Explorer.
  3. Navigate to the project's Analyzer folder and delete it.
  4. Reopen the project in Flare and select the Analysis ribbon to utilize any of the scanning tools. The feature should now function.

For more information about the analysis tool, see About Analysis and Reports.

The options in Flare's analysis feature are grayed out or will not function properly.

Cause

The analysis data in the project's Analyzer folder has become corrupted.

Solution

Deleting the corrupted Analyzer folder will allow Flare to create a new Analyzer folder the next time Flare is activated. Perform the following steps to removed the corrupted analysis data.

  1. Close the Flare project.
  2. Open the Flare project folder in the Windows Explorer.
  3. Select the Analyzer folder and press Delete on the keyboard.
  4. Open the Project folder.
  5. Select the Users folder and press Delete on the keyboard.
  6. Reopen the project in Flare. The analysis functions should now work.

For more information about using the analysis features, see Analysis Summary Window Pane and Enabling Analysis Scans.