Troubleshooting Search Issues

Following are issues that may occur when using the search feature in Flare.

The search feature is not finding the entered search term

Cause

If you are generating a DotNet Help or WebHelp target, there may be stop-words in the stop-words list that are preventing the search term from being found. This list can be changed in the target.

Solution

Perform the following steps.

  1. In the Project Organizer, open the Targets folder.
  2. Double-click the necessary target. The Target Editor opens.
  3. In the Target Editor, select the Search tab.
  4. Click the Include stop-words in search check box so that there is a check mark in it.

  5. Click to save your work.

For more information, see Including Stop Words in Search.

Search results are missing in HTML Help files

A common issue encountered by Microsoft HTML Help developers is when a "No Topics Found" message appears while searching a CHM file.

Cause

Typically, this is the result of an unregistered dynamic link library (DLL) file on the computer building the Help file. The DLL is named "itcc.dll" and is a component of Microsoft's CHM specification. Its purpose is to supply the operating system running Flare with the ability to build a CHM file with index and search capabilities.

A variety of software vendors (particularly those that develop Help authoring tools) distribute a copy of the itcc.dll file along with their program installation files. Should you happen to install or uninstall program with a copy of this file (e.g., a Help tool or software program from another vendor or another MadCap software tool that requires this file), it is possible for other copies of the itcc.dll file to become unregistered.

Solution

You will need to manually register the DLL using a batch file or the command line utility. After registering the DLL, build your Microsoft HTML Help output again. Then retry your search in the output.

How to register the DLL file using a batch file:

  1. In Windows Explorer, navigate to the Flare installation's \bin directory. Typically, the path is as follows (where [#]= the Flare version number):

    • Windows 7 or 8 (64-bit versions)
      • If you are using Flare 12 or later

        C:\Program Files\MadCap Software\MadCap Flare [#]\
        Flare.app\Resources\Bin

      • If you are using Flare 11 or earlier

        C:\Program Files\MadCap Software\MadCap Flare V[#]\
        Flare.app\Resources\Bin

    • Windows 7 or 8 (32-bit versions)

      C:\Program Files (x86)\MadCap Software\MadCap Flare V[#]
      \Flare.app\Resources\Bin

  2. In the bin directory, double-click the file named RegisterItcc.bat.

    This runs the batch file. If the registration is successful, a message appears telling you so.

How to register the file with the command line utility:

  1. In Windows Explorer, open the computer's System32 directory. The path is C:\Windows\System32.

  2. Right-click the application file named cmd.exe and select Run as administrator from the context menu.

  3. If the User Account Control message appears, click Yes. This allows you to use the command prompt to make changes on the system.

  4. At the command prompt, do the following:

    1. Type cd to change directories and press the SPACEBAR. Then type the path to the Flare \bin directory as shown in this example:

    2. Press Enter.
  5. At the command prompt, type: registeritcc.bat. Then press Enter. This runs the batch file. If the registration is successful, a message tells you so.

  6. Click OK to acknowledge the message.
  7. Close the command prompt.

WebHelp Plus output's search function will not work

After publishing a new WebHelp Plus output, the output's search will not work . The "Loading" image hangs until the output is closed.

Cause

This may be a result of a missing FLSFS file. This is the Flare search filter set file.

Solution

Copy a new FLSFS from a blank Flare project into the working project. Perform the following steps.

  1. Create a new Flare project. Select File > New Project > New Project. The Start New Project Wizards Opens.
  2. Complete all the steps in the New Project Wizard.
  3.  In the new Flare project, create a new search filter set . This can be done by performing the following steps
    1. Do one of the following, depending on the part of the user interface you are using:

      • Ribbon Select the Project ribbon. In the Content section select New > Advanced > Search Filter Set.

      • Tool Strip Select Project > Advanced > Add Search Filter Set.
      • Right-Click In the Project Organizer, right-click on the Advanced folder and from the context menu select Add Search Filter Set.

      The Add File dialog opens.

    2. In the File Type field at the top, make sure Search Filter Set is selected.
    3. In the Source area select one of the following:

      • New from template ClosedRead more… Choose either the factory template file or one of your own customized template files as a starting point. The new file will take on all of the settings contained in the template. If you want to use the factory template provided by Flare, expand the Factory Templates folder and click on a template file. If you want to use your own customized template file, expand the appropriate folder and click on a file. See About Templates.
      • New from existing ClosedRead more… Choose an existing file of the same type as a starting point for your new file. As with template files, your new file will take on all of the settings contained in the file you select. To use this option, click the browse button , use the Open File dialog to find a file, and double-click it.

    4. (Optional) If you want to place the file into a subfolder previously created in the Project Organizer, in the Folder field click and select the subfolder. Otherwise, keep the default location. See Creating Subfolders.
    5. In the File Name field, type a new name for the search filter set. You may want to use the same name that you used for the previous search filter set.
    6. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the bottom of the dialog. Next to the Condition Tags field, click and select the conditions you want to apply. Click OK. See Applying Conditions to Content.
    7. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the dialog. Next to the File Tags field, click and select the file tags you want to apply. Click OK. See Associating Tags with Files.
    8. Click Add. The search filter set is added to the Advanced folder in the Project Organizer. The Search Filter Set Editor opens to the right, with an initial search filter entry shown.
  4. In the Windows Explorer, open the new Flare project's Project folder.
  5. Open the Advanced folder.
  6. Locate the Flare search filter set (it will have a .flsfs extension) and copy the file by selecting it and pressing CTRL+C on the keyboard). The file is copied to the clipboard.
  7. Open the working Flare project's Project folder.
  8. Open the Advanced folder.
  9. Paste the file into the folder by pressing CTRL+V on the keyboard.
  10. Build and publish the WebHelp output.

For more information, see Adding Search Filter Set Files to Projects.