Troubleshooting WebHelp Plus Output Issues

Following are issues that may occur when generating WebHelp Plus output with Flare.

WebHelp Plus output's search function will not work

After publishing a new WebHelp Plus output, the output's search will not work . The "Loading" image hangs until the output is closed.

Cause

This may be a result of a missing FLSFS file. This is the Flare search filter set file.

Solution

Copy a new FLSFS from a blank Flare project into the working project. Perform the following steps.

  1. Create a new Flare project. Select File > New Project > New Project. The Start New Project Wizards Opens.
  2. Complete all the steps in the New Project Wizard.
  3.  In the new Flare project, create a new search filter set . This can be done by performing the following steps
    1. Do one of the following, depending on the part of the user interface you are using:

      • Ribbon Select the Project ribbon. In the Content section select New > Advanced > Search Filter Set.

      • Tool Strip Select Project > Advanced > Add Search Filter Set.
      • Right-Click In the Project Organizer, right-click on the Advanced folder and from the context menu select Add Search Filter Set.

      The Add File dialog opens.

    2. In the File Type field at the top, make sure Search Filter Set is selected.
    3. In the Source area select one of the following:

      • New from template ClosedRead more… Choose either the factory template file or one of your own customized template files as a starting point. The new file will take on all of the settings contained in the template. If you want to use the factory template provided by Flare, expand the Factory Templates folder and click on a template file. If you want to use your own customized template file, expand the appropriate folder and click on a file. See About Templates.
      • New from existing ClosedRead more… Choose an existing file of the same type as a starting point for your new file. As with template files, your new file will take on all of the settings contained in the file you select. To use this option, click the browse button , use the Open File dialog to find a file, and double-click it.

    4. (Optional) If you want to place the file into a subfolder previously created in the Project Organizer, in the Folder field click and select the subfolder. Otherwise, keep the default location. See Creating Subfolders.
    5. In the File Name field, type a new name for the search filter set. You may want to use the same name that you used for the previous search filter set.
    6. (Optional) If you want to apply condition tags to the file, expand the Attributes section at the bottom of the dialog. Next to the Condition Tags field, click and select the conditions you want to apply. Click OK. See Applying Conditions to Content.
    7. (Optional) If you want to apply file tags, expand the Attributes section at the bottom of the dialog. Next to the File Tags field, click and select the file tags you want to apply. Click OK. See Associating Tags with Files.
    8. Click Add. The search filter set is added to the Advanced folder in the Project Organizer. The Search Filter Set Editor opens to the right, with an initial search filter entry shown.
  4. In the Windows Explorer, open the new Flare project's Project folder.
  5. Open the Advanced folder.
  6. Locate the Flare search filter set (it will have a .flsfs extension) and copy the file by selecting it and pressing CTRL+C on the keyboard). The file is copied to the clipboard.
  7. Open the working Flare project's Project folder.
  8. Open the Advanced folder.
  9. Paste the file into the folder by pressing CTRL+V on the keyboard.
  10. Build and publish the WebHelp output.

For more information, see Adding Search Filter Set Files to Projects.