Creating Templates

After creating a template folder, you can add one or more template files to it. A template is simply an existing file or element of the same type that you are creating (e.g., a project, topic file, target file, snippet file). See Templates.

You can create templates of entire projects or individual files within a project. There are two ways to create a template from an individual file: (1) with the file open and (2) from the Template Manager.

How to Create a Template of an Entire Project

  1. Create a project, adding all of the content, elements, and settings that you want to be part of the project.
  2. Select Project > Save Project As Template. The Save Project As Template Wizard opens.
  3. In the Template Folder section, select the folder where you want to store the template files.
  4. The Template Name field, enter a name for the new template.

  5. Click Next.
  6. On the next page of the wizard, make sure a check mark is next to each content folder or file that you want to include in the project template. By default, all of the boxes are checked, but you can click in any of the boxes to remove the check marks if necessary.

  7. Click Next.
  8. On the next page of the wizard, make sure a check mark is next to each project folder or file that you want to include in the project template. By default, all of the boxes are checked, but you can click in any of the boxes to remove the check marks if necessary.

  9. Click Finish.

How to Create a File Template—File Open

  1. In Flare create the element (e.g., topic, target, skin, master page ) that you want to use as a template.
  2. Add content or settings to the element as you normally would. When you use the template to create more elements in the future, those new elements will start out with the same content or settings as your template file.
  3. Do one of the following, depending on the part of the user interface you are using:
    • Ribbon Select File > Save > Save As Template.
    • Tool Strip Select File > Save As Template.

    The Save As Template dialog opens.

  4. In the Template Folder section, select the folder where you want to store the template file.
  5. The Template Name field, enter a name for the new template.

  6. Click OK.

How to Create a File Template—Template Manager

  1. In Flare create the element (e.g., topic, target, skin, master page) that you want to use as a template.
  2. Add content or settings to the element as you normally would. When you use the template to create more elements in the future, those new elements will start out with the same content or settings as your template file.
  3. Click to save your work.
  4. Select Tools > Manage Templates.

    The Template Manager opens.

  5. In the built-in tree, find and select the folder where you want to store the template file.
  6. Click .

  7. In the dialog that opens, find and double-click the file that you want to add as a template.
  8. In the Save As Template dialog click OK.
  9. In the Template Manager dialog click Close.

What’s Noteworthy?

Note When you save a file (e.g., topic, page layout) as a new template and select a template folder, the appropriate template subfolder is automatically added to that folder (e.g., topic templates are stored in a subfolder called "Content"; page layout templates are stored in a subfolder called "PageLayouts"). If you open the main template folder in Windows, you will notice the subfolders within it. Do not rename these subfolders. If you decide to create template subfolders manually, you must be careful to name them exactly the same as Flare names automatically.

Note You can also create a project template when exporting files from another project. See Exporting Projects.

What’s Next?

After you create a template, you can select it whenever you create a new element of the same type (e.g., you can select a topic template when creating a new topic).