Exporting Projects

Export Projects

You can export an entire Flare project, or parts of one, to another location. One reason you might want to use this feature is to quickly and easily make a copy of projects and archive them, especially if you have an extremely large Flare project and need to archive only parts of it. Another use for this feature is translation. If you only need a portion of a master project to be translated, you don't want to send the translator all of the files, but rather a smaller version of the project containing only the files requiring translation.

You can export a project using the Export Project Wizard to guide you. Alternatively, you can add an export file to your project and use the Export Project File Editor.

How to Export a Project via the Export Project Wizard

  1. Open a project.
  2. Select Project > Export Project. The Export Project Wizard opens.
  3. In the New Project Name field, enter a name for the exported project.
  4. (Optional) The New Project Path field is automatically populated with the default location (Documents\My Project Exports). If you want to export the project to a different location, click and select the folder you want.

    Note If you select Project Template below in step 6, this area is grayed out because the project files will automatically be placed in your templates folder.

  5. In the Export From drop-down, select one of the options.
    • Entire Project This option makes a copy of the entire project, including all folders, subfolders, and files.
    • Using Target This option uses the same workflow as that used for generating a target. When you select a particular target, the same files and content that would be included in generated output are included in the exported project. See Step 4: Developing Targets.
    • Using Conditions This option exports only files and content affected by condition tags that you tell Flare to include or exclude. See Conditions.
    • Using File Tags This option exports only files affected by file tags that you tell Flare to include or exclude. This method can be especially useful for translation purposes, exporting only files that are marked with a certain file tag status (e.g., Ready for Translation). See File Tagging.
    • Select Files This option exports only specific files that you select. You can choose any files stored in the source project's Content Explorer and Project Organizer.

    If you have a master TOC, page layout, or stylesheet set in the Project Properties dialog and include those files in an export, the settings in the Project Properties dialog will be preserved. If you do not include those files in an export, default files are added to the exported project to allow it to work, and the settings in the Project Properties dialog are set to default.

    Example You can open the Project Properties dialog from the Project ribbon.

    Let's say the Defaults tab looks like this:

    Notice that the fields point to specific files.

    Suppose you export this project and include the TOC and styles files in the export, but you do not include the page layout file. In that case, the Project Properties dialog will look like this in the exported project:

    Note If Flare detects any missing files (e.g., stylesheet, master page, target) that are necessary in order to properly open the exported project, default files are added. For example, if no target file is added directly as a result of your selection, an HTML5 target is added by default.

  6. In the Output drop-down, select one of the options.
    • Zip File This option packages the project files into a single zip file with an .flprjzip extension and places it in a location that you select. The default location is Documents\My Project Exports.
    • Project Files This option simply exports the project files to a location that you select. The default location is Documents\My Project Exports.
    • Project Template This option exports the project files to your templates folder (e.g., Documents\My Templates\Projects). By being placed in this location, the project files become available as a template selection when you create a new project. See Templates and Creating Templates.
  7. (Optional) Select Save settings if you want to retain your settings for future re-exports. The export project file (.flexp) is stored in the Exports folder in the Project Organizer. When you open this export file, the Export Project File Editor opens. This editor lets you change any of your settings (if necessary) and export the project again (see the set of steps below for exporting a project using the Export Project File Editor).
  8. Click Next.
  9. If you are exporting based on a target, click in the Target drop-down field and select the appropriate target from the source project.
  10. (Optional) You can select one or both of the following:
    • Convert variables to text Select this option if you want all relevant variables to be converted to text.
    • Convert snippets to text Select this option if you want all relevant snippets to be converted to text.
  11. If you are exporting an entire project or using a target, you can skip to step 12. Otherwise, if you made another selection in step 5, click Next and complete the options as necessary.

    If Using Conditions

    Use either the Basic or Advanced section to tell Flare which condition tags to include and which to exclude from the export.

    By default when you open this page, the Basic option is selected. You can click Advanced to switch to that mode if you are experienced at writing expressions by hand. While the Basic section is easier for most people to use, it is also more limited in the type of expressions it can create.

    With the Basic method, all of your work is done in the top half of the user interface, by just selecting options. On the other hand, with the Advanced method, most of your work is done in the bottom portion of the user interface.

    For details and examples on using each of these methods, see Creating Basic and Advanced Tag Expressions.

    Note In order for this method to work, make sure you have already applied the appropriate condition tags to files and content in the project. See Applying Conditions to Content.

    Note If you are an experienced user and want to use the Advanced mode, you might find it helpful to begin with the Basic mode to create the initial expression and then switch to Advanced when you are ready.

    Note The Finish button is not enabled until you create at least one condition expression on this page.

    If Using File Tags

    1. In the Tag Type field, you can select a specific file tag set or choose to display all file tags to the right.
    2. Use either the Basic or Advanced section to tell Flare which file tags to include (e.g., Ready for Translation) and which to exclude from the export.

      By default when you open this page, the Basic option is selected. You can click Advanced to switch to that mode if you are experienced at writing expressions by hand. While the Basic section is easier for most people to use, it is also more limited in the type of expressions it can create.

      With the Basic method, all of your work is done in the top half of the user interface, by just selecting options. On the other hand, with the Advanced method, most of your work is done in the bottom portion of the user interface.

      The process for creating file tag expressions is essentially the same as that for condition tag expressions. Therefore, for details and examples, you can refer to Creating Basic and Advanced Tag Expressions and substitute file tags wherever condition tags are mentioned.

      Note In order for this method to work, make sure you have already associated the appropriate file tags with files in the project. See Associating Tags With Files.

      Note If you are an experienced user and want to use the Advanced mode, you might find it helpful to begin with the Basic mode to create the initial expression and then switch to Advanced when you are ready.

      Note The Finish button is not enabled until you create at least one file tag expression on this page.

    If Select Files

    1. Make sure a check mark is next to each content folder or file that you want to include in the exported project. By default, all of the boxes are checked, but you can click in any of the boxes to remove the check marks if necessary. You can expand folders and subfolders to see files within them.

    2. Click Next.
    3. Make sure a check mark is next to each project folder or file that you want to include in the exported project. By default, all of the boxes are checked, but you can click in any of the boxes to remove the check marks if necessary. You can expand folders and subfolders to see files within them.

  12. If you are exporting project files or zip files (step 6), click Finish. The project is exported, and Windows opens to the location, showing you the project or zip files. However, if you are exporting to a template, continue with the wizard and complete the remaining options.

    If Project Template

    1. Click Next.
    2. On the next page of the template, select the template folder where you want to export the files. You can click Manage Templates if you need to add or change template folders. See Templates and Managing Templates.
    3. In the Template Name field, enter a new name for the template.
    4. Click Finish. The project is exported, and Windows opens to the location, showing you the files.

How to Export a Project via the Export Project File Editor

  1. Add an export file to your project via the previous set of steps using the Export Project Wizard. You can also do this manually (see Adding an Export Project File).
  2. Open the Project Organizer.
  3. Double-click the Exports subfolder.
  4. Double-click the appropriate export file.

    The Export Project File Editor opens. At minimum a General tab is shown, with basic export settings.

    Depending on your selection in the Export From or Output field, the editor changes to show additional tabs when needed.

    • If you choose Entire Project, the Start tab is shown, as well as an Options tab for converting variables and snippets to text.

    • If you choose Using Target, the Start tab is shown, as well as a Target Options tab so that you can adjust those settings, as well as convert variables and snippets to text.

    • If you choose Using Conditions, the Start tab is shown, as well as an Options tab for converting variables and snippets to text and a Conditional Text tab so that you can include and exclude conditions.

    • If you choose Using File Tags, the Start tab is shown, as well as an Options tab for converting variables and snippets to text and a File Tag Expression tab is shown so that you can include and exclude file tags.

    • If you choose Select Files, the Start tab is shown, as well as an Options tab for converting variables and snippets to text. In addition, a Content Files tab is shown so that you can adjust content file selections, and a Project Files tab is shown so that you can adjust project file selections.

    • If you choose Project Template, a Template Path tab is also shown so that you can select a template folder to store the exported project. You can also use this tab to manage your templates.

  5. (Optional) Adjust the settings on any of the relevant tabs:

    Start Tab

    • Source Project This field displays the path and name of the current project. You cannot edit this field.
    • New Project Name Enter a name for the exported project.
    • New Project Path The New Project Path field is automatically populated with the default location (Documents\My Project Exports). If you want to export the project to a different location, click and select the folder you want.

      Note If you select Project Template in the Export From field, this area is grayed out because the project files will automatically be placed in your templates folder.

    • Export From Select one of the following:

      • Entire Project This option makes a copy of the entire project, including all folders, subfolders, and files.
      • Using Target This option uses the same workflow as that used for generating a target. When you select a particular target, the same files and content that would be included in generated output are included in the exported project. See Step 4: Developing Targets.
      • Using Conditions This option exports only files and content affected by condition tags that you tell Flare to include or exclude. See Conditions.
      • Using File Tags This option exports only files affected by file tags that you tell Flare to include or exclude. This method can be especially useful for translation purposes, exporting only files that are marked with a certain file tag status (e.g., Ready for Translation). See File Tagging.
      • Select Files This option exports only specific files that you select. You can choose any files stored in the source project's Content Explorer and Project Organizer.

      Note If Flare detects any missing files (e.g., stylesheet, master page, target) that are necessary in order to properly open the exported project, default files are added. For example, if no target file is added directly as a result of your selection, an HTML5 target is added by default.

    • Output Select one of the following:

      • Zip File This option packages the project files into a single zip file with an .flprjzip extension and places it in a location that you select. The default location is Documents\My Project Exports.
      • Project Files This option simply exports the project files to a location that you select. The default location is Documents\My Project Exports.
      • Project Template This option exports the project files to your templates folder (e.g., Documents\My Templates\Projects). By being placed in this location, the project files become available as a template selection when you create a new project. See Templates and Creating Templates.

    Options Tab

    • Convert variables to text Select this option if you want all relevant variables to be converted to text.
    • Convert snippets to text Select this option if you want all relevant snippets to be converted to text.

    Target Options Tab

    • Target Select the appropriate target from the source project.
    • Convert variables to text Select this option if you want all relevant variables to be converted to text.
    • Convert snippets to text Select this option if you want all relevant snippets to be converted to text.

    Conditional Text Tab

    Use either the Basic or Advanced section to tell Flare which condition tags to include and which to exclude from the export.

    By default when you open this page, the Basic option is selected. You can click Advanced to switch to that mode if you are experienced at writing expressions by hand.While the Basic section is easier for most people to use, it is also more limited in the type of expressions it can create.

    With the Basic method, all of your work is done in the top half of the user interface, by just selecting options. On the other hand, with the Advanced method, most of your work is done in the bottom portion of the user interface.

    For details and examples on using each of these methods, see Creating Basic and Advanced Tag Expressions.

    Note In order for this method to work, make sure you have already applied the appropriate condition tags to files and content in the project. See Applying Conditions to Content.

    Note If you are an experienced user and want to use the Advanced mode, you might find it helpful to begin with the Basic mode to create the initial expression and then switch to Advanced when you are ready.

    File Tag Expression Tab

    In the Tag Type field, you can select a specific file tag set or choose to display all file tags to the right.

    Use either the Basic or Advanced section to tell Flare which file tags to include (e.g., Ready for Translation) and which to exclude from the export.

    By default when you open this page, the Basic option is selected. You can click Advanced to switch to that mode if you are experienced at writing expressions by hand. While the Basic section is easier for most people to use, it is also more limited in the type of expressions it can create.

    With the Basic method, all of your work is done in the top half of the user interface, by just selecting options. On the other hand, with the Advanced method, most of your work is done in the bottom portion of the user interface.

    The process for creating file tag expressions is essentially the same as that for condition tag expressions. Therefore, for details and examples, you can refer to Creating Basic and Advanced Tag Expressions and substitute file tags wherever condition tags are mentioned.

    Note In order for this method to work, make sure you have already associated the appropriate file tags with files in the project. See Associating Tags With Files.

    Note If you are an experienced user and want to use the Advanced mode, you might find it helpful to begin with the Basic mode to create the initial expression and then switch to Advanced when you are ready.

    Content Files Tab

    Make sure a check mark is next to each content folder or file that you want to include in the exported project. By default, all of the boxes are checked, but you can click in any of the boxes to remove the check marks if necessary. You can expand folders and subfolders to see files within them.

    Project Files Tab

    Make sure a check mark is next to each project folder or file that you want to include in the exported project. By default, all of the boxes are checked, but you can click in any of the boxes to remove the check marks if necessary. You can expand folders and subfolders to see files within them.

    Template Path Tab

    • Template Folder Select the template folder where you want to export the files.
    • Manage Templates Select this option if you want to add or change template folders. See Templates and Managing Templates.
    • Template Name Enter a new name for the template.
  6. Click to save your work.
  7. At the top of the Export Project File Editor, click Run Export Project File. The project is exported, and Windows opens to the location, showing you the files.

Examples

Example — Archive Using Conditions

You have a large Flare project, from which you create single-sourced output for four products. Furthermore, let's say that the documentation for each of those products consists of several targets in the Flare project (e.g., some online, some print-based outputs).

In order to keep the output separate and organized throughout the Flare project, you use condition tags, both on content and on the files themselves (e.g., topics, images, stylesheet).

Your manager says that each time you finish documentation for a particular product, you must save just those files in a repository. So let's say one day you finish the documentation for Product 1, which you've designed to produce output from three targets (one output for the Web, and two outputs for PDFs).

Your large Flare project holds the finished documentation for Product 1, but it also holds the documentation for Products 2, 3, and 4, which are in different stages of progress. You want to archive only the documentation that is specific to Product 1, so you decide to export the relevant files from the large Flare project to a smaller one.

But how do you do this? One option is to export to a smaller project based on condition tags, which you have used to organize all of the content and files in the project.

So from the Project ribbon you click Export Project. On the first page of the wizard, you click in the Export From drop-down and select Using Conditions.

You can then tell Flare which conditions to include and which to exclude. In this case, you tell Flare to include all of the condition tags that have to do with Product 1 and its targets, and you exclude all of the condition tags that have to do exclusively with the other products and their targets.

After clicking Finish, the relevant files and content are exported to a new, smaller Flare project.

Example You have a Flare project with seven targets, and you need to translate the content associated one of those targets from English to French. You could send the entire Flare project to the translator, but that would mean the translator would be getting files associated with all seven targets, not just the one requiring translation. So you decide to export only the portion of the Flare project that needs to be translated.

First, from the Project ribbon you click Export Project. On the first page of the wizard, you click in the Export From drop-down and select Using Target.

On the next page of the wizard, you select the target whose files you want to export. In this case, let's say the target in question is named "Product1_Web Output." In addition, you tell Flare to convert variables and snippets to text so that they become part of the topics, rather than separate files.

After clicking Finish, the relevant files and content are exported to a new, smaller Flare project, which you send to the translator. Only the files and content necessary to produce the Product1_Web Output target are included in the export. Therefore, the translator receives only the files requiring translation.

What’s Noteworthy?

Note As an alternative to exporting projects in the Flare user interface, you can use madbuild to export projects from the command line. Using this method, you do not need to have Flare open, and you can schedule exports for specific days and times. See Exporting Projects Using the Command Line.

Note There is also a less robust, but quicker feature for zipping projects. See Zipping Projects.