Templates

A template is an existing project or file that serves as the basis for a new one, providing preset content, settings, or formatting.

In most cases, Flare provides you with one or more templates (called "factory templates"), so you do not need to worry about coming up with your own. However, if you want, you can create your own templates and use them when you create new projects or add new elements to a project. Templates can be especially useful when you are working on a team.

General Information

Process

  1. Creating Template Folders
  2. Creating Templates
  3. Managing Templates
  4. Select a template when creating a new project or file.

General Information

Process

  1. Creating Template Folders
  2. Creating Templates
  3. Managing Templates
  4. Select a template when creating a new project or file.

Example You are working with a team of 10 other writers, and you want to create a topic called "Welcome" that all authors should use in their projects. The template topic will contain some standard text and headings. In addition, the topic links to a stylesheet, which automatically gives the topic the appropriate look and feel. The idea is the authors will create a "Welcome" topic in each of their projects, adding more content to that topic as needed; all "Welcome" topics should be consistent and look the same in all projects.

To accomplish this, you first open a Flare project and create the topic. It might look something like this:

Now you need to make sure that you have a template folder ready to hold the new template file. Therefore, you select the Tools ribbon. In the Templates section you click Manage Templates. This opens the Template Manager.

In the dialog that opens, you find and select the folder where you want to store the template file.

After closing the Template Manager, you make sure your new topic is still open. Then you select File > Save > Save As Template. In the dialog that opens, you select the new template folder and click OK.

Now let's say that Karen, one of the other authors, wants to create a "Welcome" topic for a new project she is working on. In her Flare project, she selects Project > New > Topic. In the dialog that opens, she selects the template file you created, chooses a location (in the following example, the root folder), and provides a name for the new file. Then she clicks Add.

The new topic is added to the Karen's project. In order for her topic to look just like your topic, she needs to add the same stylesheet file to her project. This can be done by simply importing that file (see Importing Stylesheets and Adding Images to Projects) or maybe through Global Project Linking (see Global Project Linking—Importing Files From Other Projects).

Once Karen brings the stylesheet file into her project, she can associate it at the project, target, or topic level. Let's say she sets it at the project level (in the Project Properties dialog, which is opened by selecting Project > Project Properties). After doing this, her topic will look just like yours, and she can begin adding content to it.