Analysis

The following are project analysis issues that might occur involving background code when working in Flare Desktop.

Analysis Feature in Flare Desktop Does Not Work

Problem

When using the project analysis feature in Flare Desktop, the following error message occurs: Problem(s) in FileList background thread: Index was out of range. Must be non-negative and less than the size of the collection.

Cause

The analysis database might be corrupted. This can be the result of a Microsoft SQL writing problem.

Solution

Delete the Analyzer folder from the Flare project. This removes the corrupted analysis database, and Flare Desktop generates a new database the next time the project is opened.

To accomplish this, perform the following steps.

  1. Close the project in Flare Desktop.
  2. Open the project folder in Windows Explorer.
  3. Navigate to the project's Analyzer folder and delete it.
  4. Reopen the project in Flare Desktop and select the Analysis ribbon to utilize any of the scanning tools. The feature should now function.

For more information about the analysis tool, see Analysis Ribbon.

Analysis Feature Options are Grayed Out

Problem

The options in Flare Desktop's project analysis feature are grayed out or are not functioning properly.

Cause

The analysis data in the project's Analyzer folder has become corrupted.

Solution

Deleting the corrupted Analyzer folder allows Flare Desktop to create a new Analyzer folder the next time Flare Desktop is activated. Perform the following steps to removed the corrupted analysis data.

  1. Close the Flare project.
  2. Open the Flare project folder in the Windows Explorer.
  3. Select the Analyzer folder and press DELETE on the keyboard.
  4. Open the Project folder.
  5. Select the Users folder and press DELETE on the keyboard.
  6. Reopen the project in Flare Desktop. The analysis functions should work.

For more information about using the analysis features, see Analysis Summary Window Pane and Enabling Analysis Scans.